Dashboard and reporting performance degraded

Incident Report for Radar

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 18:42 EDT

Update

Dashboard and reporting performance are now operational. Data on some pages and reports is delayed, but catching up.
Posted Oct 20, 2025 - 16:38 EDT

Monitoring

Dashboard and reporting performance continues to be degraded. Data on some pages and reports is delayed, but catching up.
Posted Oct 20, 2025 - 15:53 EDT

Update

Dashboard and reporting performance continues to be degraded. This incident is related to an ongoing AWS service disruption.
Posted Oct 20, 2025 - 11:17 EDT

Identified

Reports are loading intermittently, but performance is still degraded.
Posted Oct 20, 2025 - 07:45 EDT

Investigating

Reporting performance is degraded. This incident is related to an ongoing AWS service disruption and an earlier incident (https://status.radar.com/incidents/2w04wqy39ylw). We are investigating.
Posted Oct 20, 2025 - 06:44 EDT
This incident affected: Dashboard.