Elevated API Latencies

Incident Report for Radar

Resolved

This incident has been resolved.
Posted Feb 04, 2025 - 07:38 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2025 - 07:13 EST

Investigating

We're experiencing an elevated level of API latencies and are currently looking into the issue.
Posted Feb 04, 2025 - 06:55 EST
This incident affected: APIs (Search APIs, Geocoding APIs).